Cyrillic 1.1

Guide for Demonstration
Disk

Cyrillic is a program for drawing family trees and managing
pedigree data. It will be useful in hospitals and laboratories
where genetic information is handled on a routine basis. The
program is designed to work with IBM PCs or compatibles
running Windows 3.1 with at least 2 Mb of RAM.

The demonstration version of the program on the
accompanying disk is intended for evaluation purposes only
and has several limitations.

« There is a limit of 15 persons in a family (the full application
can handle up to 1,000 persons in a single family).

- The options to save or import files have been disabled.

-« While a sample family can be printed, any printout will bear
a legend explaining that it comes from a demonstration
version of the program.

« The full program is accompanied by a manual of 200 pages.
This brief guide introduces you to some of the key features
and gives an indication of the program's scope, but it is
intended to give you a glimpse rather than the full story.
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An Example
Family

Running the Cyrillic demonstration

To install the Cyrillic demonstration put the disk into your disk
drive and in the Windows Program Manager, select the Run
option from the File menu.

-=-‘ Run

Command Line: K

‘a:\setup | Cancel

CJRun Minimized Browse...

Help

Type a:\setup in the dialog box and press <return>. You will
be asked to confirm the directory for installation.

=-‘Insta|lati0n of CYRILLIC for Windows 3.1c\famirees

Setup will install this application into the following
directory, which it will create on your hard disk.

If you want to install the application in a different directory
and/or drive, type the name of the directory below:

Copyio: |CAFAMTREES

| 0K | ‘Qﬂncel |

Press <return> to accept the default directory unless you wish
to change it. The Cyrillic files will now be copied to your hard
disk and a program group and icon will be created in the
Windows Program Manager.

=| cvriLic |+[=

ac

CrRILLC
pedigres
editor

To run the demonstration program double click on the Cyrillic
icon in the Windows Program Manager.

On your demonstration disk you will find a sample family
'DMDTest5.fam'. Select the file by choosing Open from the File
menu. We will now guide you through some features of
Cyrillic, but if you are confident with Windows programs why
not explore the family yourself through the menus and the tool
bar?
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= CYRILLIC - [CAFAMTREES\DMDTESTS.FAM] EE
File Edit ©Options Format Inputioutput Windows Help

First, let us take a look at the menu system. The main headings:
File, Edit, Options, Format, Input, Windows and Help group
the principal functions of the program. Pull down the Edit
menu and choose the Family Information option. You will see
a dialog box with various items of information, for example that
this is a family with Duchenne Muscular Dystrophy. Note that
there are several areas in the dialog box where you can enter
additional data.

Family identity information

Family 1D number : | DMD 5

| |Cance||| OK |

Family name : |

Select family markers Num indidividuals in family: 11

Max Num Individuals: 1000

Family condition : |Duchenne muscular dystrophy (Aff) |

GQuantitative value : | | + ‘

Comments: |0.011

«[ [+

Date of original information :

I
I

Date of last update :

Now take a look at the Input/output and the Help options. If
you experiment with the Windows menu you will find that you
can change the tool bar into a floating palette which can be
moved around your family tree. This is particularly useful
when working with large families. Let us now use some of
these tools.

First a general hint. Cyrillic works on the Object/Action
principal. You select an individual or a group of individuals
(the Object) and then you apply some Action to your selection.
These actions are grouped in the menus and can also be
invoked by clicking on the buttons in the tool bar. A second
hint. You select an individual by pointing to it with the mouse
and clicking with the left mouse button. If you want to select
more than one individual, or an area from a family tree, hold
the mouse button down and drag across your tree. Try this
technique to select two or three individuals and then apply one
of the tools to your selection by clicking the relevant button (try
'Marker', 'Spouse’ or 'Ind Dat'). Notice that you cycle through
the individuals you have selected and at each stage you can
change data associated with the individuals by typing in the
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Editing Patient
Data

dialog boxes. As you work with Cyrillic you will find that there
are plenty of short-cuts and some of these are mentioned on the
menu.

You may nowlike to explore the family by using some of the
tools. Select a married individual and click on the 'Spouse'
button. You will find a 'Partnerships' dialog box, which you
can use to change the 'kind of relationship' to 'separated' or
'divorced' (click in the check boxes). Notice what effect this has
on the family tree. Now select an individual by clicking on the
'Ind dat' button.

=| Individual data form

Other ‘O Normal |!|
: Cancel
- _ Gonetic symbale
orenames : I—I ‘ O Clear symbol |!|
Known as : Additional bols *
¥
Maiden name : ‘ | ‘ O Clear symbol |!|
Address : + i
}:‘ Multiple .. |Singleton 3
3| Preg :
Additional info: L Liability class : _
New line = = 1
Ctrl+Enter =1
C : + +
L1 ‘ = C Male @ Female O Sex unknown
= Pedigree number : I1:4
1 [ Disconnect from parents
Date of Date of ‘Addiliunal data...| Identifier :
[ Proband 1 &l markers unknown [0 Adopted [ Possibly adopted

Change the Genetic Symbol representing the individual by
selecting one from the scrollable list in the dialog box.

=| Individual data form
Other ‘O Normal |!|
: Cancel
- _ Gonetic symbale
prenames : I—I O Clear symbol *
Knownso: [ | [0 Ciear symbol B
@ Unaffected N
Maiden name : ‘ | ® Af o
Address : @  Heterozygous
@ Possibly affected E
> ql
Additional info: @ a2
New line = w g3
Ctrl+Enter o g4
C : 1 ¥ ql+q2
@ ql+qd n
™ ql+q4 [+]
= [ Disconnect from parents
Date of Date of Additional data...| Identifier :
birth : ‘ death : ‘ ‘ I:I
[ Proband 1 &l markers unknown [0 Adopted [ Possibly adopted

Next, select an individual and use the 'hide' or 'desc' buttons to
see what you can do with these buttons. When you have
performed an action with these tools you can use Display full
family in the Options menu to return to the full family tree.
Finally, try moving some of the individuals on the tree. Point
to an individual with the mouse and drag the person, with the
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Drawing a new
family

mouse button depressed, to a new location. You may also
move a portion of the family tree by selecting some part of it
and dragging the highlighted rectangle to the new location.
The ability to move individuals or branches of the tree, by
pointing and clicking is very handy when you need to make
additions to a family. Before we draw a family from scratch try
experimenting with some of the menu options and tools on the
tool bar. Note that often additional features are available by

using the right mouse button.

Now that you have taken a general look at the program, this
section provides a step-by-step guide to producing a simple
drawing. To draw a pedigree for a new family, select the New
option from the File menu. If you are already working on a
drawing, you will be asked whether you want to store this
information. Since saving is disabled in this demonstration
version of Cyrillic, select the No button in the dialog box. The
screen will then be cleared and the 'Family identity information'

dialog box will be displayed.

=-| Family identity information

Family ID number : ‘(]|

‘ ‘Cancel|| QK |

Family name : |

Select family markers Num indidividuals in family: 0

Max Mum Individuals : 1000

Family condition : ‘

|

Guantitative value : ‘

4]

Comments :

«[ [»

Date of original information :

Date of last update :

I
I

Once you have entered any information on the family, click on
the OK button. Position the cursor where you want the first
individual to appear on screen and click on the left mouse
button for a female or the right button for a male. The
'Individual data form' dialog box appears.
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Individual data form

Surname : l:l DPregnam:y outcomes :
Other ‘O Normal |l|

Genetic bols :
Forenames : I—I ‘O Clear symhnl |g|
Known as : ’—| Additi ¥ .
Maiden name : ‘ | ‘ O Clear symbol |g|
Address : Multiple .. |Singleton 3

preg

Additional info:
New line =
Ctrl+Enter

c .

1

DERBIRRE

+

C Male @ Female O Sex unknown

Pedigree number : I1:4

[ Disconnect from parents
Date of

Date of
birth :

L I« T I+]1*

‘Addiliunal data...

Identifier
e [ 1]

[ Proband

1 &l markers unknown [0 Adopted [ Possibly adopted

Enter any information on the first individual and choose OK.
The first symbol is displayed on screen. You can now enter
family members related to this person. Position the cursor over
the symbol and click the right mouse button. The 'Relationship
of new individual' dialog box now appears.

=-| Relationship of new individual
Select the relationship of the new
individual to their relative.
[ Mother | [ Eather | [ ware | [Husband |
Daughler | $on | | Sisler | | Brother |
|§%af§nskr | | Labidd | Sifsding |
‘Moszoz;f‘(g(suxéwiiz‘ | Dzygous bwin | | Ty 997 |
‘ friptet H Gumdrunied || Guntuplet |
Sextuptel
| Unconnected individual | Cancel

Click on the button for the appropriate relationship. This
removes the dialog box and changes the cursor to indicate that
you are entering a new relation. Position the cursor where you
want the symbol to appear and click the left mouse button. You
will now be presented with another 'Individual data form'
dialog box for the new relation. Enter any relevant information
and click on the OK button. The new symbol will be displayed
on the screen with a line joining it to the first individual you

entered.
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=] CYRILLIC- [NoName] -]~
File Edit Options Format Inputioutput Windows Help
Bars | Loops | Guan | Delete | Marker [ Spouse | Ind dat | Space [Reduce | Desc | Hide [Relative|+]

|

«[ +

You can now draw the rest of the family using the same
principles, remembering that the demonstration version allows
a maximum of 15 individuals.

Further Cyrillic has far too many features to be described in detail in a
explorations short guide like this. Please experiment with the various
options on the Format menu to discover how virtually every
aspect of the drawing can be controlled to match your
particular needs. Look also at the Edit menu options Edit
Markers and Edit Diseases to examine the facilities Cyrillic
offers for defining and recording disease and marker

—] CYRILLIC- [CACYRILLICIFAMTREES\EX3.FAM] [EE
File Edit Options Format Inputioutput Windows Help
Bars | Loops | Quan | Delete | Marker | Spouse | Inddat | Space | Reduce | Desc | Hide | Relative]|t]

~=-‘ List of disease loci

Disease name :
Becker Muscular Dystrophy (Quan) Edit...
Coronary disease
Cystic Fibrosis
Duchenne muscular dystrophy
Duchenne muscular dystrophy (Aff)
Duchenne muscular dystrophy (Quan) Newjdiseas
Fra(X) Mental Retardation
Huntington's disease
LDL Cholesterol levels
Norries disease

Oto-palato-digital syndrome |

Reads BMD.
Reads L{ = Information about a disease
Spinal m| Is
Spinal m| Duchenne muscular dystrophy (Aff) s
Test dis 12
® Affection O Quantitative 3
.
Frequency of disease allele : | 0.000200 =
7 iz
Chromosome : -
Male mutation rate : | 0.000100
Female mutation rate : | 0.000100
[ Set default markers for disease |
— —_ —_ —_ —_
16 m7 ms 1 m2 m3 L4
? M EM EM ™ [isPh SENT |
«[ 1 ]
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The ideal tool
for creating
family trees

and managing
genetic
information

Cyrillic

We think you'll agree that Cyrillic is the most user-friendly and
powerful pedigree drawing software on the market. We believe
that Cyrillic and Microsoft Windows provide a winning
combination of simplicity, publication-quality output, and
powerful information management tools.

Cyrillic comes with a comprehensive user manual. This
includes a tutorial, and detailed chapters on pedigree drawing,
adding data, genetic markers, importing files, and outputting
data to linkage analysis programs.

If you have any technical questions about Cyrillic ring Cherwell
at any of the numbers below.

Don’t you wish you were using Cyrillic today? Telephone, fax,
or send your order direct to Cherwell Scientific at one of the
following addresses.

Cherwell Scientific Publishing Ltd Cherwell Scientific Publishing
The Magdalen Centre c/o0 CHEM Research GmbH
Oxford Science Park Beethovenstrafse 7 B

Oxford OX4 4GA D-60325 Frankfurt

United Kingdom Germany

Tel: +44 (0)1865 784800 Tel: 069-7411114

Fax: +44 (0)1865 784801 Fax: 069-740496

Internet: csp@sable.ox.ac.uk

Cherwell Scientific Publishing, Inc
744 San Antonio Road

Palo Alto

CA 94303

Tel: (415) 852 0720

Fax: (415) 852 0723




